Viewpoint for Projects (UK) - Upload Failures
Incident Report for Viewpoint Construction Software
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 10:59 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 22, 2021 - 10:31 GMT
Investigating
We are currently investigating this issue.
Posted Feb 22, 2021 - 10:10 GMT
This incident affected: UK / EMEA (Viewpoint for Projects).