Viewpoint Help - intermittent issues
Incident Report for Trimble Viewpoint
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 18:49 UTC
Update
We are continuing to investigate this issue.
Posted Sep 20, 2021 - 18:22 UTC
Investigating
Viewpoint Help is currently down. We are working to resolve this as quickly as possible. Please check back for more updates.
Posted Sep 20, 2021 - 17:42 UTC
This incident affected: North America (Viewpoint Help).