Spectrum (North America) - Performance degradation
Incident Report for Viewpoint Construction Software
Resolved
The remediation activities our Engineering team undertook have continued to show positive results.

All performance & stability metrics are now back within acceptable thresholds.

Sincere apologies for the disruption caused by this incident.
Posted Feb 26, 2021 - 13:02 GMT
Monitoring
Our monitoring has continued to show improvements across the platform in terms of both performance & stability.

Engineering are continuing to ensure that performance remains within acceptable thresholds.
Posted Feb 25, 2021 - 18:42 GMT
Update
Our monitoring is showing a improvement but our Engineering teams are continuing to work on the issue to restore performance to acceptable levels for all users.

Apologies for the disruption this has caused.
Posted Feb 25, 2021 - 16:49 GMT
Update
We are continuing to work on a fix for this issue.
Posted Feb 25, 2021 - 15:43 GMT
Update
Engineering are continuing investigations towards addressing the root cause of the issue.

Apologies for the disruption caused.
Posted Feb 25, 2021 - 13:59 GMT
Update
Our engineering teams are continuing investigations towards addressing the root cause of the intermittent performance issues users are experiencing.

Sincere apologies for the inconvenience caused.
Posted Feb 25, 2021 - 10:02 GMT
Update
Our engineering team continue to work on a solution to address the performance issues being experienced.

Apologies for the inconvenience this has caused.
Posted Feb 25, 2021 - 05:46 GMT
Update
Our engineering team are continuing to work on a solution to address the performance issues being experienced.

Apologies for the inconvenience this has caused.
Posted Feb 24, 2021 - 23:16 GMT
Update
A solution to the issue has been identified & we are in the process of implementing & communicating to those affected.

Sincere apologies for the inconvenience caused.
Posted Feb 24, 2021 - 21:25 GMT
Update
We are continuing to work on a fix for this issue.
Posted Feb 24, 2021 - 19:50 GMT
Update
Our engineering team are continuing to investigate the root cause of the issue.

We apologize for the disruption caused.
Posted Feb 24, 2021 - 18:04 GMT
Identified
We are aware of customers experiencing degraded performance, our Engineering team are investigating.

Apologies for inconvenience caused.
Posted Feb 24, 2021 - 16:30 GMT
This incident affected: North America (Spectrum).