Spectrum (North America) - Performance Degradation
Incident Report for Trimble Viewpoint
Resolved
This incident has been resolved.
Posted May 11, 2021 - 11:17 UTC
Identified
Some users may be continuing to experiencing performance issues, we are working to address performance for all those affected.

Apologies for the inconvenience caused.
Posted May 10, 2021 - 21:23 UTC
Monitoring
The remediation activities our Engineering team have undertaken are showing positive results with performance & stability metrics now back within acceptable thresholds.

We are continuing to monitor all systems very closely.
Posted May 10, 2021 - 17:35 UTC
Update
We are continuing to work on a fix for this issue to restore performance to acceptable levels for all users.

Sincere apologies for the inconvenience caused.
Posted May 10, 2021 - 16:42 UTC
Identified
We have identified an issue causing performance degradation for a subset of customers. Operations teams are working to implement a mitigation.
Posted May 10, 2021 - 14:38 UTC
This incident affected: North America (Spectrum).