Viewpoint Enterprise Cloud (North America) - Cloud Access Issue
Incident Report for Viewpoint Construction Software
Resolved
This incident has been resolved.
Posted Mar 30, 2021 - 23:19 BST
Monitoring
Access to cloud environments should now be restored. We will continue to monitor affected environments to ensure full recovery.
Posted Mar 30, 2021 - 21:41 BST
Investigating
We are currently experiencing an issue where some VEC customers are unable to access their cloud environment or the Cloud Workspace admin website.
Posted Mar 30, 2021 - 19:46 BST
This incident affected: North America (Viewpoint Enterprise Cloud).