Procontractor Cloud login issue
Incident Report for Trimble Viewpoint
Resolved
This issue has been resolved.
Posted Oct 14, 2020 - 17:42 UTC
Identified
We are of an issue affecting PCC customers and their ability to login. The cause of the issue has been identified and we are working to resolve it.
Posted Oct 14, 2020 - 16:37 UTC
This incident affected: North America (ProContractor Cloud).