Planned Maintenance on ProContractor Cloud Service
Maintenance
2026-09-27T12:00:00.0000000Z
Planned Maintenance on ProContractor Cloud Service
Status: closed
Start:
2026-09-27T02:00:00.0000000Z
End:
2026-09-27T12:00:00.0000000Z
Duration: 10 hours
Affected Components:
ProContractor Cloud
ProContractor Cloud - NA
Update
2026-09-27T02:00:00.0000000Z
2026-09-27T02:00:00.0000000Z
Dear Valued Trimble Viewpoint Customers
We will be undergoing scheduled maintenance during this time.
Affected Services: ProContractor Cloud
Start Date and Time: September 27 2026, 02:00 UTC
Expected Duration: 10h
Resolved
2026-09-27T12:00:00.0000000Z
2026-09-27T12:00:00.0000000Z
Dear Valued Trimble Viewpoint Customers
Planned Maintenance Affecting Service(s): ProContractor Cloud
Please be advised that the previously notified Planned Maintenance has been completed successfully.