Service Unavailability (Multiple Applications)

Incident Report for Trimble Viewpoint

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 18:17 UTC

Monitoring

The issue has been mitigated, and all services should now be fully restored.
Posted Apr 15, 2026 - 16:15 UTC

Identified

Microsoft has begun restoring power in the region, and some services may start to come back online. However, full service restoration is still in progress.
Posted Apr 15, 2026 - 15:47 UTC

Update

We are continuing to investigate this issue.
Posted Apr 15, 2026 - 15:07 UTC

Update

Microsoft has notified us that this is a power-related issue impacting the Azure West US 2 region. This may affect service availability or performance for some resources.

Microsoft is actively working to restore full power and service as quickly as possible. We are monitoring the situation closely and will provide updates as more information becomes available.
Posted Apr 15, 2026 - 14:57 UTC

Investigating

We are currently experiencing availability issues affecting multiple applications hosted in the Azure West US 2 region. We are actively working with Microsoft to resolve the issue. Additional updates will be provided as more information becomes available.
Posted Apr 15, 2026 - 14:45 UTC
This incident affected: North America (Vista, ProContractor Cloud, Viewpoint Enterprise Cloud, Spectrum).