Viewpoint Analytics - Invoice Processing Issue
Incident Report for Trimble Viewpoint
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 16:44 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 16, 2024 - 20:16 UTC
Investigating
We're currently addressing an issue impacting invoice processing, affecting invoices stuck in the 'In Process' status within the Completed tab for Vista enterprises.

Apologies for the inconvenience caused.
Posted Feb 14, 2024 - 19:55 UTC
This incident affected: North America (Viewpoint Analytics).