Potential Outage for MFA Notifications

Incident Report for Trimble Viewpoint

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 19:31 UTC

Investigating

We are currently investigating this issue.
Posted Jul 02, 2026 - 15:38 UTC
This incident affected: North America (Vista, ProContractor, Viewpoint Team, Spectrum, Viewpoint Analytics, HR Management (For Spectrum), Service Tech, HR Management (For Vista), Financial Controls, Field Management & Field Service, Viewpoint Traqspera, Auto Invoice, ProjectSight, B2W Estimate).