Turbo SMTP is currently experiencing a global outage caused by a fire at their provider’s data center in Amsterdam. This infrastructure failure began at approximately 11:45 p.m. PST on May 6 (8:45 a.m. local time on May 7).
Because of the nature of this outage, Vista emails sent during this window (specifically those with attachments like Pay Stubs or AR Statements) cannot be automatically recovered or resent by the system.
Recommended Actions for Vista Customers: 1. Confirm if you’re affected. In Vista, open VA Site Settings and review the Email Settings tab. If your Host references Turbo SMTP, your site is likely affected. 2. To restore email functionality immediately: We recommend transitioning to an internal provider such as Microsoft 365 or Google Workspace. This is the recommended best practice for Vista to ensure better deliverability and security. - Vista 2024 R1 or later: You can update these settings yourself in VA Site Settings > Email Settings. - Vista 2023 and earlier: Please review this guide for the necessary testing steps, then contact Support to finalize the configuration. https://support.viewpoint.com/s/knowledgedetail?c__urlname=Changing-from-Turbo-SMTP-to-email-service-of-your-choice 3. Check the VA Message Archive within your application to see which communications did not send. 4. If you detect failed outbound messages please re-run the related process (i.e. PR Paystub Notify) in Vista to successfully send your messages.
We will provide further updates as Turbo SMTP shares more information regarding their restoration timeline.
Posted May 08, 2026 - 00:28 UTC
Identified
Turbo SMTP is currently experiencing a global outage affecting email delivery services due to a critical infrastructure issue. Customers using Turbo SMTP as their SMTP provider may encounter failures with email-dependent workflows, including AR Statements and Pay Stubs.
To restore email functionality as quickly as possible, customers are advised to transition to an internal SMTP provider such as Office 365 or Google Workspace. Product-specific configuration guidance is available through support resources.
We will continue to share updates as additional information becomes available.
Posted May 07, 2026 - 19:03 UTC
This incident affects: North America (ProContractor Cloud, Viewpoint Enterprise Cloud, Viewpoint for Cloud).