Service Tech Mobile
Incident Report for Trimble Viewpoint
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 15:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2023 - 17:32 UTC
Investigating
We are investigating an issue with customers being unable to access Service Tech Mobile. We are aware of the issue and will update the status page when the root cause has been identified.
Posted Jun 01, 2023 - 13:50 UTC
This incident affected: North America (Service Tech).