Spectrum (North America) - System availability impacted
Incident Report for Viewpoint Construction Software
Resolved
This incident has been resolved.
Posted Apr 30, 2021 - 18:53 UTC
Monitoring
A fix has been implemented and all client connectivity should now be restored.
Posted Apr 30, 2021 - 18:38 UTC
Identified
We are aware of an issue where users are encountering issues accessing their cloud environments.

Our Engineering team have identified the issue & are addressing.

Apologies for the inconvenience caused.
Posted Apr 30, 2021 - 18:12 UTC
This incident affected: North America (Spectrum).