Viewpoint Team (North America) - Issues accessing areas of the application
Incident Report for Trimble Viewpoint
Resolved
All issues should now be resolved.

We are continuing to monitor the system closely & apologies for any disruption you may have experienced today
Posted Nov 25, 2020 - 18:07 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 25, 2020 - 18:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2020 - 16:56 UTC
Update
The issue affecting poor performance of Forms is now also resolved and we are continuing to investigate the issues experienced when creating or modifying distribution groups.

Sincere apologies for any inconvenience caused.
Posted Nov 25, 2020 - 16:08 UTC
Identified
The issue affecting navigating folder structures is resolved but we are continuing to investigate issues surrounding distribution group functionality & observed poor performance of Forms.

Apologies for any disruption caused.
Posted Nov 25, 2020 - 15:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2020 - 14:28 UTC
Investigating
We are aware of some issues navigating through certain areas of the application, including folder structures & distribution groups.

We are currently investigating, apologies for any inconvenience caused.
Posted Nov 25, 2020 - 13:43 UTC
This incident affected: North America (Viewpoint Team).