Some Jobpac Connect Customers are experiencing Degraded Performance

Incident Report for Trimble Viewpoint

Resolved

Dear Valued Trimble Customers

The additional measures deployed over the last two days have resulted in greater consistency across our system benchmarks, with no new cases of degraded performance since these measures were implemented.

On that basis, we are now moving the status of this Issue to Resolved. However, we will maintain our vigilance and monitor the situation very closely. Of course, should you experience any degraded performance issues please reach out to us directly

Your patience and understanding have been genuinely appreciated.

Kind regards
Posted Feb 07, 2025 - 00:30 UTC

Update

Dear Valued Trimble Customers

Thank you for your continued patience and understanding.

We have deployed additional hardware resources, which has resulted in an improvement in performance and overall stability. Pleasingly, no further cases of degraded performance have been reported since these measures were put in place. However, we remain alert and continue to monitor the situation very closely.

We will be deploying a Networking upgrade tomorrow morning, which should assist further, as well as looking at other options to provide additional robustness and reliability.

In the interim, if you experience any issues relating to Jobpac Connect speed or stability please ensure you log a Support case so we can assist.

Kind regards
Posted Feb 06, 2025 - 05:43 UTC

Update

Dear Valued Trimble Customers

We continue to work through the reported incidents of Degraded Performance with affected customers.

For the vast majority of users, Jobpac Connect performance is consistent and stable. However, we remain in contact ongoingly with our partners and have stressed the importance of resolving this as quickly as possible. All available resources are assisting.

Please ensure that if you experience any degraded performance issues, even intermittently, you create a case so we can work with you directly.

Thank you for your continued patience and understanding and our sincere apologies for any disruptions.

Kind regards
Posted Feb 05, 2025 - 23:28 UTC

Update

Dear Valued Trimble Customers

We have had some additional customers reporting degraded performance issues.

We are working with our partners with all available resources to have this resolved as quickly as possible. On that basis, we will move the impact of this Issue from Operational to Degraded Performance to reflect the current situation.

A gentle reminder that if you do happen to experience any degraded performance issues please create a case so we can work with you directly.

Thank you for your continued patience and understanding and our sincere apologies for any disruptions.

Kind regards
Posted Feb 05, 2025 - 01:29 UTC

Update

Dear Valued Trimble Customers

We have been vigilantly monitoring our system performance and in constant collaboration with our suppliers. While for the majority of our customer's performance is within the preferred threshold we do have a very small number of users who have reported degraded performance issues.

We are investigating these instances as a priority and working with these customers directly. Please note if you do happen to experience any degraded performance issues please create a case so we can work with you directly.

Thank you for your continued patience and understanding and our sincere apologies for any disruptions.

Kind regards
Posted Feb 05, 2025 - 00:53 UTC

Update

Dear Valued Trimble Customers

We have had some isolated reports of degraded performance this morning which we have been investigating. System performance for this very small number of customers should now be restored.

We will continue to monitor our systems diligently to ensure we maintain the optimal level of performance. We will keep the status as Monitoring for the time being and only mark this as Resolved once we are absolutely satisfied.

As mentioned, if you happen to experience any degraded performance issues please create a case so we can engage with you directly. Thank you for your continued patience and understanding.

Kind regards
Posted Feb 03, 2025 - 00:30 UTC

Monitoring

Dear Valued Trimble Customers

System Performance is showing both better speed and stability since we carried out the optimisation of our infrastructure yesterday. We have had no further examples of degraded performance so we can now move this Issue to Monitoring.

Rest assured we remain vigilant and will continually monitor the system to ensure there are no further interruptions. Please note if you do experience any degraded performance issues please reach out to us directly.

Thank you for your patience and understanding. We are genuinely sorry for any inconvenience this has caused.

Kind regards
Posted Jan 30, 2025 - 22:29 UTC

Update

Dear Valued Trimble Customers

We continue to work with our infrastructure providers and have investigated and tested a number of different scenarios to help us identify the root cause. We have identified several opportunities that should assist and have already carried out one of these changes which have further optimised our infrastructure.

We will continue to work through the remaining action items to build more speed and stability in our system.

Thank you for your patience and understanding. We are genuinely sorry for any inconvenience this has caused.

Kind regards
Posted Jan 30, 2025 - 03:34 UTC

Update

Dear Valued Trimble Customers

We have been working with our infrastructure providers overnight to restore performance. While we have been able to see an improvement we will continue to work with our providers until we are satisfied the performance and stability of the system is where it needs to be.

We will therefore keep this issue open until we have the required confidence and assurances in place.

In the interim customers should see better speeds today however, if you do encounter any degraded performance issues please do not hesitate to reach out to us.

We appreciate your ongoing support and patience.

Kind regards
Posted Jan 29, 2025 - 22:37 UTC

Update

Dear Valued Trimble Customers

We continue to investigate this issue as a priority working in direct collaboration with our partners. We have all available resources focused on this so a solution can be remedied as swiftly as possible.

As mentioned if you happen to experience any degraded performance issues please create a case so we can engage with you directly. Thank you for your continued patience and understanding.

Kind regards
Posted Jan 29, 2025 - 03:22 UTC

Investigating

Dear Valued Trimble Customers

Some Jobpac Connect users are experiencing slowness. Please note we are investigating the situation as a priority and working to restore normal performance levels as quickly as possible.

In the interim, we do apologise for any inconvenience this has caused and thank you for your patience and understanding.

If you do experience any degraded performance issues please ensure you log a case so we can ensure all impacted customers are tracked and communicated with directly. As soon as we have further details we will post them on this page

Kind regards
Posted Jan 29, 2025 - 02:00 UTC
This incident affected: Australia / New Zealand (Jobpac Connect).