Traqspera Outage

Incident Report for Trimble Viewpoint

Resolved

This incident has been resolved.
Posted Jan 22, 2026 - 14:02 UTC

Investigating

We are currently investigating this issue.
Posted Jan 22, 2026 - 13:22 UTC
This incident affected: North America (Viewpoint Traqspera).