We are continuing to monitor for any further issues.
Posted Oct 30, 2025 - 05:29 UTC
Monitoring
We are seeing most applications in a recovered state at this time. We will continue update until all applications are fully recovered.
Posted Oct 29, 2025 - 20:45 UTC
Update
Microsoft has updated their timeline and now estimates that the rollback process may take up to an additional 4 hours to complete before full recovery is achieved. We will continue to monitor progress and share updates as more information becomes available.
Posted Oct 29, 2025 - 19:57 UTC
Update
Microsoft has started rolling back the configuration changes that caused this issue. We are beginning to see recovery in some applications, though not all are fully restored yet. We will provide another update as additional services recover.
Posted Oct 29, 2025 - 18:28 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 29, 2025 - 17:01 UTC
Identified
Microsoft Azure continues to experience global DNS issues, which is affecting access to some of our applications that rely on their services. We continue to work closely with Microsoft on the issue.
Posted Oct 29, 2025 - 17:00 UTC
Update
We are continuing to investigate this issue.
Posted Oct 29, 2025 - 16:34 UTC
Investigating
We are aware that several Trimble applications are currently unavailable due to a global network issue affecting Microsoft Azure. This issue is impacting access to our Azure-hosted applications. Our teams are actively working with Microsoft to resolve the problem, and we will continue to provide updates on our status page as more information becomes available.
Posted Oct 29, 2025 - 16:13 UTC
This incident affects: North America (ProContractor, ProContractor Cloud, Viewpoint Enterprise Cloud, Viewpoint for Cloud, Viewpoint Field View, Spectrum, Work Center, B2W Operational Suite).