Spectrum (North America) - Performance Degradation
Incident Report for Viewpoint Construction Software
Resolved
The remediation activities our Engineering team undertook have continued to show positive results.

All performance & stability metrics have maintained within acceptable thresholds.
Posted Apr 20, 2021 - 10:57 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 19, 2021 - 17:58 UTC
Monitoring
The remediation activities our Engineering team have undertaken are showing positive results with performance & stability metrics now back within acceptable thresholds.

We are continuing to monitor all systems very closely.

Apologies for the inconvenience this has caused today.
Posted Apr 19, 2021 - 17:58 UTC
Update
We are continuing to work on a fix for this issue to restore performance to acceptable levels for all users.

Sincere apologies for the inconvenience caused.
Posted Apr 19, 2021 - 16:27 UTC
Update
We are continuing to work on a solution to address the performance issues being experienced for everyone impacted. Remediation actions are being taken & some customers may already be seeing improvements.

Sincere apologies for the inconvenience caused.
Posted Apr 19, 2021 - 14:40 UTC
Identified
Our engineering team are continuing to investigate the root cause of the issue affecting a subset of customers.

Updates will be provided as soon as available.

Apologies for the disruption this morning.
Posted Apr 19, 2021 - 13:14 UTC
Investigating
We are aware of customers experiencing degraded performance, our Engineering team are investigating.

Apologies for inconvenience caused.
Posted Apr 19, 2021 - 11:56 UTC
This incident affected: North America (Spectrum).