This incident has been resolved, and Viewpoint Help is now accessible. Thanks for your patience.
Posted Sep 23, 2024 - 22:53 UTC
Investigating
The Viewpoint Help site is not accessible. We're investigating the issue and will provide an update when the issue is resolved. Sorry for the inconvenience.
Posted Sep 23, 2024 - 15:00 UTC
This incident affected: North America (Viewpoint Help).