TrimbleID - Sign In Failed

Incident Report for Trimble Viewpoint

Resolved

This incident has been resolved.
Posted Sep 10, 2026 - 15:17 UTC

Investigating

We are aware that users are unable to sign in to Viewpoint for Projects and/or Field View via Trimble ID when using the Google, Apple, or Microsoft login options.

While this is being investigated, you can continue to access your desired application via your Trimble ID username and password.

We apologise for any inconvenience caused by this incident and are working urgently to resolve it.
Posted Sep 10, 2026 - 13:20 UTC
This incident affected: UK (Viewpoint Field View, Viewpoint for Projects, Viewpoint Team).