Viewpoint Field View (UK) - Degraded Web & Mobile Sync Performance

Incident Report for Trimble Viewpoint

Update

The forms module is now available.
Posted Mar 13, 2026 - 11:24 UTC

Update

We are aware of an issue with the forms module and are working to reinstate this.
Posted Mar 13, 2026 - 11:21 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 13, 2026 - 09:31 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 12, 2026 - 14:59 UTC
This incident affects: UK (Viewpoint Field View).