Viewpoint Field View (UK) - Web Service Degradation
Incident Report for Trimble Viewpoint
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 14:52 UTC
Investigating
We are investigating failures concerning file uploads, reporting & bulk downloads.
Posted Oct 11, 2024 - 12:57 UTC
This incident affected: UK (Viewpoint Field View).