Traqspera Android Application Issue
Incident Report for Trimble Viewpoint
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 18:47 UTC
Identified
The issue has been identified, and we are working to resolve the issue.
Posted Sep 06, 2024 - 20:02 UTC
Investigating
The Traqspera Android app is currently experiencing issues. We are investigating the issue and will update you as soon as the root cause has been identified.
Posted Sep 06, 2024 - 19:27 UTC
This incident affected: North America (Viewpoint Traqspera).