Scheduled Patch Installation: Trimble Jobpac Connect 2026.3.1

Scheduled for Sep 18, 11:00 - 11:30 UTC

Scheduled

Dear Valued Jobpac Connect Customers,

We are pleased to announce that Jobpac Connect patch 2026.3.1 will be deployed to all customers on Friday, 18th September 2026, at 9 PM AEST and there will be a 30 minute downtime during which the system will not be available.

The details of the changes are:

Module - Accounts Payable
Creditor upload (CRED) updated regarding details for contacts 'ACCOUNT' and 'SALES'.
- Zendesk Ticket# 7424

When editing an existing AP payment batch, updated the Batch Selection screen so adjusted part payment amounts and the Total Amount To Be Paid accurately reflect generated preview reports.
- Zendesk Ticket# 8049

Updated logic when re-using a previously deleted creditor code to prevent retention of previous historical data (such as Extended Name and Email Address).
- Zendesk Ticket# 8215

Payments Status tab display updated in Accounts Payable Transaction Enquiry for transactions with multiple payments.
- Zendesk Ticket# 8314

The AP Invoice uploads (CREDBAL and INVOICES) currently permits negative values for Invoices and positive values for Credits. To maintain consistency with manual entry screens, validation has been updated to require positive values for Invoices and negative values for Credits.
- Zendesk Ticket# 8338

Updated individual invoice batching logic when used with authoriser ranges so that required approvers remain consistent across submission and batching.
- Zendesk Ticket# 8427

Updated the Accounts Payable Enquiry screen display for the Batched User and Authorised By User fields.
- Zendesk Ticket# 8447

Updated Creditor Summary Listing Excel report layout handling for address fields containing double quote characters.
- Internal

Improved stability in AP Site Enquiry when clearing the Start Job and Finish Job filter fields for a Creditor.
- Internal

Module - Business Forecasting
On the Job Dates screen in BFM, updated the Defects Period field behavior during prior historical periods. Additionally, adjusted handling for field modifications to preserve contract duration and days ahead/behind values, and updated historical views and the BFM Project Summary Report to reference corresponding historical records.
- Zendesk Ticket# 3992

Module - Fixed Assets
Updated the Depreciation Exception Report generation process when system parameter FADPEX is unassigned or blank.
- Zendesk Ticket# 9127

Module - General Ledger
Updated Standard P&L report formatting when generating an Excel export sequentially following a PDF export.
- Zendesk Ticket# 8352

Module - Mobile
Ongoing development for the Jobpac Mobile application.

Module - Payroll
[Enhancement] Enhanced the Excel export generated from the Single Touch Payroll Submission screen to include the Qualifying Earnings column.

Updated formatting on the first detail row in the Single Touch Payroll Submission screen download report.
- Internal

Updated pre-populated pay run handling when generating the Accumulated Pay Details Report.
- Internal

Updated the ETS Preview screen in the ETS Bulk Approval menu (Actions > Post Preview) to display comments across all rows.
- Internal
Module - Progress Claims
Updates to Materials on Site (MOS):
Updated PC Claim Entry for Materials on Site (MOS) to ensure modified values update smoothly when preparing a progress claim prior to AR posting.
Updated PC Certified Claim Entry for Materials on Site (MOS) item management and value recalculation for associated progress claims.
Updated the Copy Current to Previous function to preserve MOS values.
- Zendesk Ticket# 7709

Updated the Head Contract Progress Claim Report default Claim Date logic to align with the current AR accounting period.
- Zendesk Ticket# 8249

Module - Purchase Orders
Updated Purchase Order final approval processing to ensure order commitment.
- Zendesk Ticket# 8378

Updated the total approval count on the Maintain User Approvals screen to dynamically refresh upon approving or rejecting a purchase order.
- Internal

Updated Purchase Order Maintenance tab views to consistently display purchase order items across all tabs.
- Internal

Module - Subcontracts
Updated the 'SC Variations by Cost Centre Report' display for the 'S/C Ref.' field.
- Zendesk Ticket# 6734

Updated Subcontract Variations Upload (SCVARS) processing for accurate value and internal variation handling.
- Zendesk Ticket# 7752

Updates in the PTA Reconciliation Reports including Minor Updates towards QBCC certification.
- Internal

Module - System Administration
[Enhancement] Continuing development for integration with EMS and self serve Licensing.

Module -Variations
Updated navigation and confirmation flow upon approving a Head Contract (HC) Variation via the HC Variation Approval screen.
- Internal

Module - Web Services/Interfaces
[Enhancement] Continuing development for Swagger Documentation.

[Web Services] Updated the CreateNewPlantTimesheet API endpoint to support plant timesheets with negative idle time values.
- Zendesk Ticket# 4072

[Web Services] Updated response handling for CreateANewVariation API when creating variations within existing variation groups.
- Internal

Module - WUI/JOM/BI/Reports/Java
[Enhancement] [WUI] Updated Progress Claim Entry to improve layout clarity and maintain UI consistency by relocating the instructional notice text above the workspace tabs, removing surrounding asterisks, and incorporating the standard blue Information icon with blue text.

[WUI] Updated the Super tab on the Pay Details screen to dynamically refresh column headers when selecting Show Qualifying Earning YTD.

[Enhancement] [JOM] Update with BuildingPoint's support details on the JOM error page.

[Reports] Updated EFT field formatting in the AP Enquiry Excel download.
- Internal

[Reports] Updated job number data formatting in the Cost Plus Billing Report Excel output.
- Internal



Thank you for your cooperation.
Best regards,
Jobpac Connect Team
Posted Sep 16, 2026 - 00:49 UTC
This scheduled maintenance affects: Australia / New Zealand (Jobpac Connect).