Service Alert: Intermittent Missing Invoice Images Issue

Incident Report for Trimble Viewpoint

Monitoring

Dear Jobpac Connect Customers,

We are writing to inform you of an issue that was introduced with the latest release (Version 2025.3.0) deployed on Saturday, November 15, 2025.

Issue Details & Current Status
Problem: Invoice images are currently not visible within Jobpac for some customers who submited the PDF images though OCR. This issue appeared to be intermittent and did not impact everyone.
Immediate Action: We have installed a fix for this issue earlier today and believe this will address the problem going forward.
Next Steps: We are currently monitoring the system and verifying the data to ensure all previously affected invoices are correctly re-linked and display properly in Jobpac.

We thank you for your patience and cooperation as we continue to work through this issue with the utmost priority.

Best regards,
The Jobpac Connect Team
Posted Nov 19, 2025 - 03:48 UTC
This incident affects: Australia / New Zealand (Jobpac Connect).