Viewpoint Field View (UK) - Mobile Sync Performance Degraded

Incident Report for Trimble Viewpoint

Resolved

This incident has been resolved.
Posted Mar 05, 2026 - 12:34 UTC

Investigating

We are currently investigating this issue.
Posted Mar 04, 2026 - 10:53 UTC
This incident affected: UK (Viewpoint Field View).