PC Mobile - July 1, 2024
Incident Report for Trimble Viewpoint
Resolved
A fix has been implemented and this incident is now resolved.
Posted Jul 01, 2024 - 15:42 UTC
Identified
The issue has been identified and the fix is being implemented. Subscribe to updates to be notified when the issue is resolved.
Posted Jul 01, 2024 - 14:25 UTC
Investigating
We are currently investigating an incident with PC Mobile. Subscribe to updates at https://status.viewpoint.com/ for up-to-date information.
Posted Jul 01, 2024 - 13:59 UTC
This incident affected: North America (ProContractor Cloud).