Viewpoint Team (US) - Performance degradation
Incident Report for Viewpoint Construction Software
Resolved
This incident has been resolved.
Posted May 12, 2021 - 15:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2021 - 21:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 11, 2021 - 21:06 UTC
Investigating
We are investigating an issue that is affecting performance for some customers.
Posted May 11, 2021 - 20:16 UTC
This incident affected: North America (Viewpoint Team).