Trimble Work Center Outage
Incident Report for Trimble Viewpoint
Resolved
This incident has been resolved.
Posted Jun 13, 2024 - 20:31 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2024 - 20:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2024 - 18:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 13, 2024 - 17:19 UTC
Update
We are continuing to investigate this issue.
Posted Jun 13, 2024 - 16:55 UTC
Investigating
There is currently an outage in the Trimble Work Center. Users are experiencing "https://workcenter.apps.trimble.com/error" when accessing.
WE are currently investigating the issue.
Posted Jun 13, 2024 - 15:33 UTC
This incident affected: North America (Work Center).