Viewpoint for Projects (UK) - Web Application Offline
Incident Report for Trimble Viewpoint
Resolved
This incident has been resolved.
Posted Dec 09, 2024 - 23:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2024 - 18:47 UTC
Investigating
We are currently investigating this issue.
Posted Dec 09, 2024 - 17:32 UTC
This incident affected: UK (Viewpoint for Projects).