Intermittent Cascade Access Issues

Incident Report for Trimble Viewpoint

Resolved

This incident has now been resolved.
Posted Jun 17, 2026 - 23:43 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 17, 2026 - 20:40 UTC

Monitoring

We have implemented a fix and are now monitoring for full resolution.
Posted Jun 17, 2026 - 20:38 UTC

Investigating

We are aware of an issue where some customers are running into intermittent access issues in Cascade and we are currently working through a full resolution, will provide updates as we roll out the fix.
Posted Jun 17, 2026 - 20:29 UTC
This incident affected: North America (ProContractor Cloud, Viewpoint Enterprise Cloud, Viewpoint for Cloud) and Australia / New Zealand (Viewpoint Enterprise Cloud).