Viewpoint for Projects [UK] - Web Performance Degraded
Incident Report for Trimble Viewpoint
Resolved
This incident has been resolved.
Posted Oct 01, 2024 - 16:15 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 01, 2024 - 15:45 UTC
Investigating
We are currently investigating this issue.
Posted Oct 01, 2024 - 15:20 UTC
This incident affected: UK (Viewpoint for Projects).