Vista Azure US East 2 issue

Incident Report for Trimble Viewpoint

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 20:48 UTC

Monitoring

A fix has been deployed, and access should now be restored. We will continue to monitor the situation.
Posted Apr 27, 2026 - 20:15 UTC

Investigating

We are currently aware of an issue impacting some Vista customers hosted in the Azure East US 2 region, where users may be unable to access the application. We are actively investigating and will continue to provide updates as more information becomes available.
Posted Apr 27, 2026 - 19:31 UTC
This incident affected: North America (Vista).