Viewpoint for Projects (EMEA) - View and Mark up - degraded performance
Incident Report for Viewpoint Construction Software
Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 09:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2021 - 07:44 UTC
Investigating
We are currently investigating this issue.
Posted Apr 29, 2021 - 07:40 UTC
This incident affected: UK / EMEA (Viewpoint for Projects).